Validar token OAuth v2 entre .Net framework y .Net core

Con la llegada de .Net core y el uso de microservicios, es posible que te enfrentes a la necesidad de que un nuevo microservicio que utiliza tecnología .Net core sea capaz de validar un token generado por un viejo microservicio (por ejemplo .Net 4.5 o .Net 4.6) que se encarga de la autenticación del usuario y la generación del mencionado token. Debido al cambio de algunas de las librerías de seguridad en .Net core, y según como tengas construido tu provider de OAuth v2 para generar el token, lograr esta validación puede no ser una tarea inmediata.

En esta entrada te muestro una de las posibles soluciones para lograrlo. 

Leer más…